[Mikrotik] Backup y Export de la configuración enviada por FTP

Como complemento a la entrada de copia de seguridad de mikrotik por mail he creado un nuevo script que realiza lo mismo, hace un export y un backup, pero en vez de enviarlo por mail lo sube a un servidor ftp.

Además tiene un parámetro de histórico, con lo que si ponemos esa opción a 1 (activa por defecto) nos sube la copia con el id del router y la fecha, como por ejemplo:


Alferez_3011_10may2017.backup
Alferez_3011_10may2017.rsc

Y si lo ponemos a 0 sube los ficheros con el nombre:

Alferez_3011.backup
Alferez_3011.rsc

######
######         Script para el envio de Backups del Mikrotik
######         genera un Backup y un Export del sistema y lo
######         sube por ftp al servidor indicado.
######
######                     www.alferez.es
######


#### Configuracion del Servidor FTP
:local server "servidorFTP";
:local port 21;
:local user "usuarioFTP";
:local password "passwordFTP";

#### Si activamos el historico sube los ficheros con la fecha del dia que se genero
:local historico 1;

:local nombrefichero;
:local systemid;

:set systemid [/system identity get name];

/system backup save name=$systemid
/export file=$systemid

:if ($historico = "1") do={
:set nombrefichero ([/system identity get name]."_".[:pick [/system clock get date] 4 6].[:pick [/system clock get date] 0 3].[:pick [/system clock get date] 7 11])

/tool fetch mode=ftp address=$server src-path=($systemid.".rsc") dst-path=($nombrefichero.".rsc") user=$user port=$port password=$password upload=yes keep-result=no
/tool fetch mode=ftp address=$server src-path=($systemid.".backup") dst-path=($nombrefichero.".backup") user=$user port=$port password=$password upload=yes keep-result=no

}

:if ($historico = "0") do={
/tool fetch mode=ftp address=$server src-path=($systemid.".rsc") dst-path=($systemid.".rsc") user=$user port=$port password=$password upload=yes keep-result=no
/tool fetch mode=ftp address=$server src-path=($systemid.".backup") dst-path=($systemid.".backup") user=$user port=$port password=$password upload=yes keep-result=no

}

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Human Verification: In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


This blog is kept spam free by WP-SpamFree.